Pages Project: site can’t provide a secure connection

Just deployed a new pages project

https://firebase-3fz.pages.dev/

Getting error:
This site can’t provide a secure connection firebase-3fz.pages.dev uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I have created many other page projects and never had this happen. Any ideas as to how to fix this?

Hi there,

Your settings all seem to be OK, so I’m thinking this might have been a deployment error.
Please try redeploying and see if it solves it.

Take care.

Tried a redeployment, still same error.

  • I am doing direct upload using wrangler.
  • I am not using a framework
  • This works locally with miniflare and using: wrangler dev
  • I originally uploaded using github and that site still exists, but it is not linked
  • I tried this on chrome and edge browsers and still have the same error.
  • This NOT a custom domain

Is this something that cloudflare has cached because of my old github deployment?

Should I setup a custom domain to get the certificate to work?

I added a custom domain to my pages project and it now serves a secure connection. So this issue is resolved. So, to have your pages project work with direct upload from wrangler, you need a custom domain - is this correct?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.