Pages - Problem deploying Hugo Web Site

Hi guys
I’m not able to deploy a Hugo Web Site (a very small web site…)
All the time I receive a generic Error…
I already re-create repository, re-deploy, change the repository, change the configuration, add the environment HUGO_VERSION and so on…

09:13:29.294 Initializing build environment. This may take up to a few minutes to complete
09:14:04.014 Success: Finished initializing build environment
09:14:04.014 Cloning repository…
09:14:07.072 Failed: an internal error occurred

Can you help me?
Thanks!

I am getting the same thing.

And it doesn’t matter if it’s Hugo or Gatsby.

Also, seems to only happen on the 2nd build.

I think I fixed it for me.

It was due to the ROOT
setting Root directory: / back to / seemed to resolve the issue
not sure why that would cause it to fail.

Thanks for your reply but i don’t understand how do you resolve the problem
I have
Build command: hugo
Build output directory: /public
Root directory: /
What do i need to change?

Sorry, then I have no idea how to fix then.

I had

Root directory: /site

And that wasn’t working

so I changed it to

Root directory: /

And that worked for me.