Pages: nuxt3

15:53:07.242 Installing NPM modules using Yarn version 1.22.4
15:53:07.848 yarn install v1.22.4
15:53:07.936 [1/4] Resolving packages…
15:53:08.215 [2/4] Fetching packages…
15:53:47.268 error [email protected]: The engine node is incompatible with this module. Expected version ^14.16.0
15:53:47.279 error Found incompatible module.
15:53:47.279 info Visit yarn install | Yarn for documentation about this command.
15:53:47.299 Error during Yarn install
15:53:47.308 Failed: build command exited with code: 1
15:53:48.139 Failed: an internal error occurred

It seems your error is due to Nuxt requiring a higher version of Node.js. In the current build image, the default is 12.18.0. You can change this via the Environment variable NODE_VERSION or .nvmrc, .node-version files, to any version up to 17.

To set a higher version of node.js, in your Pages Project Settings, under Environment variables, add an environment variable “NODE_VERSION” set to a value of 16, for both Production and Preview. Then retry the build (in the main deployments tab, the three dots to the right of each deployment, click “Retry Deployment”).

1 Like