Pages: Node.js version is too old for [email protected]

16:19:58.085	Initializing build environment. This may take up to a few minutes to complete
16:22:27.602	Success: Finished initializing build environment
16:22:27.602	Cloning repository...
16:22:32.666	Success: Finished cloning repository files
16:22:33.506	Installing dependencies
16:22:33.509	Python version set to 2.7
16:22:34.685	v12.18.0 is already installed.
16:22:35.246	Now using node v12.18.0 (npm v6.14.4)
16:22:35.294	Started restoring cached build plugins
16:22:35.297	Finished restoring cached build plugins
16:22:35.428	Attempting ruby version 2.7.1, read from environment
16:22:36.559	Using ruby version 2.7.1
16:22:36.872	Using PHP version 5.6
16:22:36.907	5.2 is already installed.
16:22:36.913	Using Swift version 5.2
16:22:36.914	Started restoring cached node modules
16:22:36.916	Finished restoring cached node modules
16:22:36.918	Started restoring cached yarn cache
16:22:36.920	Finished restoring cached yarn cache
16:22:36.924	Installing yarn at version 1.22.4
16:22:36.930	e[37mInstalling Yarn!e[0m
16:22:36.931	e[36m> Downloading tarball...e[0m
16:22:36.941	
16:22:36.941	[1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz --> /tmp/yarn.tar.gz.VbKD2oRLfd
16:22:36.942	  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
16:22:36.943	                                 Dload  Upload   Total   Spent    Left  Speed
16:22:37.068	
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    79  100    79    0     0    622      0 --:--:-- --:--:-- --:--:--   626
16:22:37.318	
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    93  100    93    0     0    247      0 --:--:-- --:--:-- --:--:--   978
16:22:37.540	
100   656  100   656    0     0   1095      0 --:--:-- --:--:-- --:--:--  1095
16:22:37.925	
100 1215k  100 1215k    0     0  1236k      0 --:--:-- --:--:-- --:--:-- 1236k
16:22:37.925	
16:22:37.926	[2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc --> /tmp/yarn.tar.gz.VbKD2oRLfd.asc
16:22:37.964	
100    83  100    83    0     0   2124      0 --:--:-- --:--:-- --:--:--  2124
16:22:37.989	
100    97  100    97    0     0   1520      0 --:--:-- --:--:-- --:--:--  1520
16:22:38.012	
100   660  100   660    0     0   7556      0 --:--:-- --:--:-- --:--:--  7556
16:22:38.117	
100  1028  100  1028    0     0   5366      0 --:--:-- --:--:-- --:--:--  5366
16:22:38.149	e[36m> Verifying integrity...e[0m
16:22:38.175	gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
16:22:38.182	gpg: Good signature from "Yarn Packaging <[email protected]>"
16:22:38.186	gpg: Note: This key has expired!
16:22:38.186	Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
16:22:38.186	     Subkey fingerprint: 6D98 490C 6F1A CDDD 448E  4595 4F77 6793 6947 5BAA
16:22:38.187	e[32m> GPG signature looks goode[0m
16:22:38.187	e[36m> Extracting to ~/.yarn...e[0m
16:22:38.240	e[36m> Adding to $PATH...e[0m
16:22:38.245	e[36m> We've added the following to your /opt/buildhome/.bashrc
16:22:38.245	> If this isn't the profile of your current shell then please add the following to your correct profile:
16:22:38.245	   
16:22:38.245	export PATH="$HOME/.yarn/bin:$HOME/.config/yarn/global/node_modules/.bin:$PATH"
16:22:38.245	e[0m
16:22:38.578	e[32m> Successfully installed Yarn 1.22.4! Please open another terminal where the `yarn` command will now be available.e[0m
16:22:38.916	Installing NPM modules using Yarn version 1.22.4
16:22:39.340	yarn install v1.22.4
16:22:39.423	[1/4] Resolving packages...
16:22:39.653	[2/4] Fetching packages...
16:22:53.133	error [email protected]: The engine "node" is incompatible with this module. Expected version ">=12.22.0". Got "12.18.0"
16:22:53.143	error Found incompatible module.
16:22:53.144	info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
16:22:53.157	Error during Yarn install
16:22:53.159	Failed: build command exited with code: 1

Found the solution!

https://developers.cloudflare.com/pages/platform/build-configuration

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.