Pages failed to create new project

Dears,
I am trying to deploy a new Pages project.

Unfortunately I am getting the following error:
An unknown error occurred (Code: 8000000)

When inspecting the network - I noticed that a request to Github return 500 with the following body:
{
“result”: null,
“success”: false,
“errors”: [
{
“code”: 8000000,
“message”: “An unknown error occurred”
}
],
“messages”:
}

I already have some Pages project up and running, It’s suddenly stopped working for creating a new one.
Attaching screenshots of the error.


Appreciate any inputs to the above situation.

Apparently you’re not the first, but in the past, it was an internal issue that showed up in the Cloudflarestatus feed.

Can you open a ticket (via email to support AT cloudflare DOT com) and post the ticket # here?

2 Likes

Thanks @sdayman,
I opened a new ticket - #2277223, hopefully they will reach out soon.

1 Like

Hey, seems to be something weird going on with Pages. The second person to report this recently. I am sending this up to the team

2 Likes

I’m having issues deploying a new site via the cloudflare API. Anyone have experience using this ?
just trying to use this Cloudflare API v4 Documentation

let project = {
“name”:“First SB Test”,
“build_config”: {
“build_command”: “npm run build”,
“destination_dir”: “dist”,
“root_dir”: “/”
},
“source”:{
“type”: “github”,
“config”: {
“owner”: “githubuser”,
“repo_name”: “myrepo”,
“production_branch”: “master”,
“deployments_enabled”: true
}
}
};

I keep just getting this response. {“result”:null,“success”:false,“errors”:[{“code”:8000000,“message”:“An unknown error occurred”}],“messages”:}

Please help! Thanks.

Hi I have created a page project previously. I want to create a new one but what I get is

An unknown error occurred (Code: 8000000)

I tried to use web console, the following request returns 500

https://dash.cloudflare.com/api/v4/accounts/{account id}/pages/connections/github
{
    "result": null,
    "success": false,
    "errors": [
        {
            "code": 8000000,
            "message": "An unknown error occurred"
        }
    ],
    "messages": []
}

Any idea?

Can you go to GitHub, delete the app and then go back to Pages and reconnect it.

If that doesn’t solve the issue please send your account ID

Tried, it doesn’t work

Can you please provide your account ID?

1 Like

868047a14e8b1dc70e227b705b7a95e6
many thanks