Pages: Deployment failed after ~30min

For the last day and a half I’ve been having issues like this:

Issue 1: The deployment fails after ~30 minutes in the “Building application” stage, without anything logged after “Success: Finished cloning repository files”. I cannot get a deployment to succeed for the life of me.

Issue 2: “Failed to start the deployment due to an internal error” (less frequent, likely irrelevant)

Things I’ve tried:

  • Retry builds
  • Delete builds, webhook deployment
  • Commit changes
  • Delete and recreate project
  • Delete and recreate project under another name
  • Disconnect/reconnect github and delete/recreate project
  • Change/remove build settings

Nothing has worked after dozens of attempts, and I’m baffled. I have nothing in logs to debug the issue. I know there was a status update and that’s roughly when my trouble started, but it has not resolved for me. Builds used to be done in ~3min before this. I’m not doing anything new or abnormal, just a simple react.js app w/ yarn.

Not heard of anyone else having problems. Could you share your pages.dev domain so that I can pass this onto the team?
(If you don’t want to share it publicly, feel free to join the Discord and DM me)

The latest is
crocpot.pages.dev

Thank you, let me pass this along

Thanks!

Hey! I found some details regarding your deployments. It does look like you are legitimately timing out on builds. There is a very unfortunate bug that causes logs to be omitted for build timeouts. The team is prioritizing this bug, and I deeply apologize for the frustration you’ve had in troubleshooting this issue.

The last thing I see in your logs before the timeout is:
Cannot find module: ‘web3’. Make sure this package is installed.
You can install this package by running: yarn add web3.

If you’d like more details or need further assistance, please DM me on our Discord or file a support ticket. You can reference this thread in the ticket so our support team knows to escalate to me directly. Thanks!

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.