Pages build times out with no error messages

Is there a way to see deeper debug logs? My pages build fails with a time out error and no diagnostic messages.

What’s the deployment ID?

If it timed out, it means it took over 20 minutes to complete per our limits: Limits · Cloudflare Pages docs

Why it took so long will be in your logs, it’s hard to get more detailed information than what tools output.

Where do I find the deployment ID?

When viewing a deployment in the dashboard, it’s the UUID at the end of the URL

Thank you! Here is the deploy ID: 11d8bd45-320a-4e93-b09c-0c0bc9717f76

It looks like for whatever reason SvelteKit hung after finishing. I see the latest prod deploy worked. I’d check to see what the changes are between these builds and see if you can figure out what change causes it. Then you can report it to the Svelte or related people.

Possible a dependency updated and has a bug.

1 Like

Walshy - I did get the site’s production build to work again by clearing the Build Cache > Clear Cache. I didn’t find any help for this problem looking through the community and support sites. There was no way of “seeing” that this was the solution, through the logs or some error on the build logs.

Great to know - thanks for the detail there. I guess the cache cleared whatever dependency problem (maybe an intermediate Git committed dependency, since removed?). Appreciate the help!

1 Like

Build cache shouldn’t have played a role here but definitely let me know if you see it again!

1 Like

I’m not sure that 1 prod build worked, but I tried another deployment, same branch, same dependencies and it timed out again (I actually canceled it before it timed out). Here’s preview deploy that is running in order to revert to an older deployment, but it’s still failing, ID: fae0b507-6a8a-42de-a159-a22705e27e52. Any insight?

I’ve tried upgrading the Build System version to 2, upgrading the Node version to 18 in environment settings, and it worked once on the preview branch. However subsequent builds failed, as have all my attempts at reverting to older builds in production. Seems like Pages builds with Sveltekit only work intermittently (timing out otherwise) with very little transparency.

After trying all of these things, what worked was removing all static generated page settings from my sveltekit app. export const prerender='auto' specifically from several routes that used it. Unfortunately, Sveltekit and Cloudflare pages messages did not offer any information to lead to this conclusion.