Pages build fail with version upgrade for Hugo site

Hi there,

when I change my Hugo version on cloudflare pages from 0.119.0 to 0.124.1 the build fails. I tested on my local machine, it builds perfectly fine with Hugo version 0.124.1. is it possible that Cloudflare have a limit to what version one can choose if yes where can I find the list of the latest Hugo version available thanks. I also tried with version 0.124.0 on Cloudflare but it failed.

Detected the following tools from environment: hugo@extended_0.124.1, [email protected], [email protected]
Installing Hugo extended_0.124.1
* Downloading hugo release extended_0.124.1...
hugo extended_0.124.1 installation was successful!
Installing project dependencies: npm clean-install --progress=false
added 186 packages, and audited 187 packages in 4s
93 packages are looking for funding
run `npm fund` for details
2 moderate severity vulnerabilities
To address all issues, run:
npm audit fix
Run `npm audit` for details.
Executing user command: Hugo --minify
/bin/sh: 1: Hugo: not found
Failed: Error while executing user command. Exited with error code: 127
Failed: build command exited with code: 1
Failed: error occurred while running build command

How can I solve this issue where Hugo builds perfectly fine on local but fail to build on cloudflare pages.

Thanks

Try making your build command use hugo and not Hugo (note the lowercase h)

1 Like

what a stupid issue :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: Autocorrect

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.