Pages adds unwanted JavaScript on top of index.html file

Hello! Could anybody please provide why Cloudflare Pages adds some script on top of the index file, and how to disable it? I really don’t see any means to turn it off. The script is placed right after the first HTML tag with attribute [data-name=“TokenSigning”].

Hey, Any chance that you enabled Web Analytics for your page? This would inject custom JavaScript into your page. You can check this by navigating to the Pages Dashboard, open your Page, then:

  • Settings
  • General

You should see a section called Web Analytics there. You can disable it to remove the JavaScript part from your page. A re-deployment is necessary for this.

Hi @jwagner! Thank you, but it is disabled, and email obfuscation is also disabled :frowning:

Could you share the exact snippet or a link to your page?

Thank you! It is available at: cyberpage.pages.dev and petrov.works.

Sorry, for some reason I can’t include the script content here.

Thanks! I don’t see any JavaScript on the site, could it be a Browser Extension you’re running?

Oh my, I’m so sorry! Stoopid me.

Huge thanks for you time @jwagner and again please forgive me for starting this.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.