PageRules Issue?

Hi,

i’m trying to create page rules to my domain but so far i wasnt able to achieve the desired goal.
What i’m trying to achieve is the following:
I have a subdomain and inside that i have specific admin area that i dont want to cache with PageRules, but i want to cache the rest of the site.

Ex: https://subdomain.domain.com/en/admin/* → Not to cache
Ex: https://subdomain.domain.com/*/ → To cache

Is this possible to do ?

Regards

Cloudflare doesn’t cache HTML by default, so your admin area shouldn’t be cached in the first place. Only JS/CSS/Images are cached.

So…what specifically are you trying to not cache in the Admin area? JS files? CSS files? Images?

If you’re not sure what is and is not cached, use your browser’s Dev Tools (F12 in Chrome) and use the Network tab to inspect each resource for the cf-cache-status header.

Hi,

i’m trying to use PageRules to cache the HTML

Regards

Then that should pretty much do it as long as whatever HTML URLs you want to cache end with a slash.

What results were you seeing?

Hi.

the results are everything is cached (include the admin area) or nothing is cached

Regards

I’m afraid that’s just something we can troubleshoot without seeing a screenshot of the actual Page Rules.

Hi,

i’ve attached a screenshot of the rules

Refards

Both of those page rules are disabled. And without the actual Page Rules, we can’t troubleshoot. Hiding the domain names makes troubleshooting impossible in this case.

Hi,

the rules are disabled because they werent working properly
The domain is https://evento.comic-con-portugal.com

Regards

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.