Page Rules sends to http even when https is set

Hi
PAGE RULES :
i´ve set a 301 rule from https:// mysite-dot-com/de to https:// mysite-dot-com/de/
Now Cloudflare sends user from /de to unsecure version http://mysite-dot-com/de/ were the user is redirected to https version https://mysite-dot-com/de/

Short

  • 301 to https /de to https /de/ is set
  • Cloudflare redirects from https /de to http /de/ and then to https: /de/

When i open https://mysite.com/de i get a 301 to unsecure “location: http://mysite.com/de/” and then another 301 to "location: https://mysite.com/de/ "

Nowhere i set redirect to http:

Any idea why?

Could you share your website URL here with us so we could double-check, troubleshoot and provide some feedback information?

Also, could you share a Page Rule too? :thinking:

Are the DNS records proxied and set to :orange:?

Are you using Cloudflare Workers, Transform Rules or even Bulk Redirects at Cloudflare dashboard?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

@fritex Sorry mate i don´t want to share domain name.

Page rule is https://mydomain.com/de 301 to https://mydomain.com/de/

DNS is proxied and running thru CF, other wise CF wouldn´t redirect anything.

Only pagerules used, no workers, no transform rules, no bulk redirects.

Tried different browsers.VPN, mobile 4g/lte, browser cache deleted…

Checked redirects with different tools also non browser tools (online) all same result…

CF still redirects from secure subfolder /de to non secure /de/ then to secure /de/ subfolder.
Optimal would be secure /de 301 to secure /de/ I don´t understand why CF is doing 301 to non ssl in the middle of the redirect.

As far as I can see, it’s just the trailing slash / difference at the end? :thinking:

Web browsers add or remove the ending slash in the URL address bar.
So if no path, or an empty path is given it is the same as just a trailing slash. It should not show up in Chromes addressbar.
The trailing slash also is always present if you for example copy a URL with no path from Chromes addressbar, but not visible. If you copy that URL, it suddenly has that trailing slash, while normally when you are on a sites root path with a trailing slash, it is not getting shown. Therefore: it is there but Chrome hides it.

You shouldn’t worry for that at all and spent a Page Rule for it.

However, are both “Always Use HTTPS” and “Automatic HTTPS Rewrites” features enabled under the SSL/TLS tab → Edge Certificates? :thinking:

@fritex Always https and auto rewrite mode is on. Opportunistic Encryption off (to prevent loading from http).

Pagerule can be spended.thats not a problem. A problem is when google search console shows me the /de is available (double content) and can´t be indexed because of redirect.But i don´t want to index it.
/de/ is already there and sitemap also included.

Since this info from google search console my site traffic dropped for my main keyword and also just for the /de/ (german version)

I think those many redirects casue a problem.This is why i want to fix it here