Page Rules - Not Working


#1

Hello, I am new to Cloudflare and have an issue.

I have setup a Page Rule that should forward to a URL. The forwarder is not working.

I have created a URL http://resources.fldusd.org/* and want it to forward to http://www.fldusd.org/apps/pages/TECH-resources

We have onsite Microsoft DNS which doesn’t have anything setup for this URL since it is a URL forwarder. (Is that even possible with Microsoft DNS?)

Not sure how I could mess this up anymore, but if anyone can help.

Thank you!


Two questions about my setup
#2

You will have to add an A record for resources subdomain in the Cloudflare’s DNS tab, and it must be proxied through Cloudflare (orange cloud).

Using DNS only (gray cloud) in DNS settings will not work.


#3

Due to the way that page rules work you will need to make sure that the URL you are trying to access is proxied through Cloudflare. Otherwise page rules will still exist but they’ll be unable to do their job.


#4

Ok, I created both the A record and the page rule.

The A record points resources to the IP address of the fldusd.sites.edlio.com.

The page rule is created and does just like I mentioned above.

Still doesn’t work.


#5

Just tested. It worked for me.
Recheck pls.

Here’s the screenshot for request url, status and response location headers.


#6

I’m trying to do the same thing - what IP address should the A record be redirecting to? The host server? The server I’m redirecting to?

Thanks


#7

It should be pointing to host/origin server.
He had this extra step because source location (subdomain) wasn’t flowing through Cloudflare. It was gray cloud or missing entry instead of orange one.


#8

Ok, thanks a lot! :slight_smile:


#9

Am I doing something wrong here?

Not sure if I have to do an A record for this. I have everything setup and working fine for the main domain, with a wildcard sending everything to a home page. But I want to set up a forward to a Facebook group for those that enter domain/forum. I setup the forward and made it rule #1, thinking that Cloudflare looks at this rule first and then the second. But no forwarding happens for /forum. Here’s a screenshot.

Am I doing something wrong?


#10

Just tested and it appears to work for me. Now the way the rule is written it works for www.advisormastery.com/forum, but not for the bare root advisormastery.com/forum. It also won’t work for /forum/ with the trailing slash… so you might add a * after forum.

You could adjust the rule to advisormastery.com/forum to catch a broader set if that makes sense for your use case.


#11

GREAT advice. I will do just that. I guess I just needed to wait longer for the DNS to update or something, but your suggestion about going without the www and adding the wildcard is perfect! Thanks!


#12

doh… formatting in the forum software took off a proceeding * before advisormastery (with no period before it will match both www and the bare root domain) and a trailing * after the word forum. Sorry I didn’t notice as I posted.


#13

Working great now for both www and without. Thanks!


#14

Hi, hopping into this thread because I’m facing similar problems. I’m trying to do the exact same thing and I’m a little confused about setting up the subdomain.

I’m not sure what is meant by:

It should be pointing to host/origin server.

Is it possible to point my subdomain to an outside URL (A google drive link)? And if so, when setting up the subdomain, what do I put as the IP address? I’m currently hosting on Github Pages, and using the IP address I use for the main domain brings up an error from Github. Completely new to this so I don’t know what I’m doing haha

Thanks for all the help!


#15

Quoted part means hosting IP, in your case Github pages IP, since you don’t have your own server. The same one as your domain, if you set it up with “A” record. If you used ANAME or ALIAS, then CF team will give you correct answer.
I am not sure what kind of setup you are making, so I am not sure will it work.

Is it possible to point my subdomain to an outside URL (A google drive link)?

Yes you can, in the page rule URL just type the Google Drive URL.

Must read stuff.


#16

still doesn’t work. what i do for this domain www.marriagemillan.com


#17

still doesn’t work. what i do for this domain www.marriagemillan.com
i already configure all this this but not redirect https


#18

It’s broken now? I can’t add page rules (DNS is orange already BTW)


#19

DNS for your root domain isn’t orange and that’s what you’re trying to redirect. It’s going straight to the origin, so Cloudflare isn’t able ot act on it with a page rule.


#20

i turn it on/off for testing, I toggle it to orange now but still error there.
Maybe i miss something there.