Page Rules not working for redirect non-www to www

Hi all,

All the solutions provided on this forum do not allow me to solve my problem. I’m trying to redirect yubigeek.com to www.yubigeek.com.

It does not work with page rules. However, I have followed a lot of discussions and it does not work.

Here are my DNS:

A => @ / server IPv4
AAAA => @ / server IPv6
CNAME => www / @

All of these DNS are configured with Cloudflare (the orange cloud enabled).

Thanks for help :slight_smile:

Your DNS records are not proxied, hence page rules won’t fire either. You first need to switch them to :orange:.

Did you read my message? I already said the orange cloud is on.

% dig +short yubigeek.com @nina.ns.cloudflare.com.
45.145.167.179

Are the nameservers at the bottom of your DNS tab nina.ns.cloudflare.com and walt.ns.cloudflare.com? If they are, then you have a bug, as the DNS requests are not returning the Cloudflare IP. If they are not, then you are looking at the wrong account.

Try turning it off and on again, but you should open a support case.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

They were proxied up until 6 days ago. The name servers have not changed in 8 months.

1 Like

Then tell me why your domain does not resolve to the proxies?

You probably paused Cloudflare.

2 Likes

Good point. That would show up on the Overview tab.

Bottom line, the records are not proxied and that’s why the page rules do not fire as I mentioned.

Whether you didn’t proxy the records, have the domain paused, or configure the wrong account is something you need to check.

Yes, Cloudflare had been on hiatus for a few days after some issues. But it didn’t work before either, and now I just activated it, it still doesn’t work.

Now they are proxied and now they should fire.

Try yourself please… https://yubigeek.com/index.php

I enabled Cloudflare on the site, and yes I’m on the correct account, I only have one.

image

Ok, it’s Google Chrome playing tricks on me, sorry I’m a noob :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.