Page Rules not working as expected

As I am a new user, I can only submit upto 4 urls . tried to minimize number of links just to make this post publishable. Apologies if this hampers the reading experience.

url_1 : example.com
url_2: blog.example.com
url_3: www.example.com

I have a CNAME record setup for the domain say url_1
The name for the record is blog and the value is set to another-url-for-website-published-on-hubspot.com . DNS proxy enabled.

We plan to make this hubspot website obsolete and redirect all the traffic that comes to url_2 to url_3

To make this happen I added a page rule as described below
<url_2>/*
forward URL: https://<url_3>/$1

This page rule is in the top most priority among others

In theory I believe this setup to work, but it is not working.
When I got to url_2, the hubspot site is served

I tried deleting the CNAME record - but then <url_2> is unresolved.

Can someone help me with this? Thanks

Can you post a picture of your Page Rules, including the actual hostnames?

@sdayman Would this screenshot help?

It’s not forwarding for me. It’s returning a 404.

You said url_1 is a CNAME for ‘blog’, but your list says url_2 is ‘blog’.

I suggest that you delete the CNAME for ‘blog’ and replace it with an “A” record with an IP address of 192.0.2.1 as a placeholder. That’s the best approach when redirecting all traffic for a hostname to something else.

General comment: underscores are not valid in domain names (or subdomains) per RFC1035, therefore you’ll likely see weird behaviour for ‘url_1’ compared to ‘url-1’, if those examples are literal.

@sdayman As suggest I added an A record for blog with target as 192.0.2.1 as shown below


The page rule for redirect is present.
Now when I visit blog.mocingbird.com, it still does not redirect to www.mocingbird.com/blog .
Can you help with a reason, why this should be happening?

@smarsh Thanks for the feedback. I will remember not to use underscore ever in the DNS names.

You’re right. It’s still not working.

Can you confirm that Sandy and Skip are your Cloudflare name servers, as listed at the bottom of your DNS settings page?

If they are, it’s possible you had previously added your site through a third party and their settings are still in effect.

The next step would be to open a ticket, then post the number here for added attention. Let us know how it goes.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.