Page rules not redirecting

I’m trying to redirect a URL using page rules (using this guide:, but it’s not taking effect at all.

I have a CNAME record proxied through Cloudflare, and I’ve cleared cache both on Cloudflare and locally, but the URL that should be redirecting just gives me a 404 page.

Does anyone know what I’m doing wrong? Thanks

Can you share the domain that should be redirecting and the rule you created?

Generally, using the new Redirect Rules is more intuitive in my experience:

1 Like

Sure, should be redirecting to, and my page rule looks like this:

(I’ve also tried %26 instead of & in the URL, but no luck)

I’ll try the redirect rules too thanks

I’ve just tried it the redirect rules way as well, but no luck. This is my rule:

I’ve tried to use your Page Rule and it works fine for me, see

So some more questions:
When you go to, do you see “Assigned Cloudflare Nameservers” as peyton and luciana? If not, you are in the wrong Cloudflare account.

If you check “Configuration Rules”, is there anything that might bypass your Page/Redirect Rules?

1 Like

Yeah I see peyton and luciana, and I don’t see anything at all under configuration rules

I guess you could try the new Trace feature and see if that helps in any way. It basically shows you what is done with your request. Does the tool even show any existing Rules?

1 Like

It does show a page rule yeah, this is what I get:

1 Like

Hmm. Maybe this is some kind of Orange to Orange (O2O) setup where your host is also using Cloudflare and their settings overwrite yours?

Definitely not too helpful if the Trace tool claims the simulated request was matched by a Page Rule when the actual request wasn’t.

1 Like

No idea, I’ll ask our host and see

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.