Page Rules not redirecting to HTTPS

I am using page rules, to redirect visitation to https://yeshemp.com from http://yeshemp.com

using the url locator I type in, yeshemp.com I still land on the “Not Secure” Site http://yeshemp.com

My settings are rule 1. https://yeshemp.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: http://www.yeshemp.com)

My settings are rule 2. yeshemp.com/
Always Use HTTPS

Wondering if I still have to do something on server side?

thanks for enlightenment

It forwards to https, but then https yeshemp redirects to http www.yeshemp and stays there. Chrome, and some other browsers, have decided to not show the www part of the hostname, hence the confusion.

Why not enable “Always Use HTTPS” in the SSL/TLS Edge Certificates section?

Thank u sdayman for the insight. I am looking into that now, and AHA!

You r da man sdayman! Thanks for helping me on this. I am the Prez of this small startup here in USA and am learning to navigate CloudFlare and you have helped immensely. I will report back tomorrow at this time to verify solution. :slight_smile:

1 Like