Page rules - is this setting not overlapping?

I am redirecting all non-https and www versions of my URLs to to the https version without the www using the #2 setting:

However, i wanted a specific URL (the one in #1) to redirect to an external website. Is the current setting in screenshot correct? Or will it follow the rule #2 regardless?

thanks for your help.

It looks all right. If the first rule fires it will redirect, if it does not it will continue with the second rule.

thanks @sandro how long does it take for the setting to take effect? I checked the URL but it is not redirecting to the external URL. it redirects instead to the homepage of the domain. so it seems it’s still reading the Rule #2 or should i wait a bit for propagation or something?

Your naked domain does not appear to be proxied, hence the page rule cant take effect. Can you switch it to :orange:?

It is @sandro

there is no option for the orange. the settings are these:

Oh I see. The issue is that unfortunately you don’t have control of the domain since Click Funnel controls the settings for it. Page Rules don’t take effect then.

I would recommend using the www subdomain.

Check it again, it isnt :wink:

Also, on the second rule, change $1 to $2, otherwise it won’t actually match the path of the URL and redirect correctly.

In this case you cant have the page rule apply to your naked domain. You should probably switch over to your www host.

It is, it always was…

$ curl -I https://drjoshwagner.com/
HTTP/2 302 
date: Wed, 19 Jun 2019 08:45:39 GMT
content-type: text/html; charset=utf-8
set-cookie: __cfduid=d169a8eb56f819d145de7660cde747ec71560933939; expires=Thu, 18-Jun-20 08:45:39 GMT; path=/; domain=.drjoshwagner.com; HttpOnly
location: https://drjoshwagner.com/youdeserveit
cf-cache-status: EXPIRED
cache-control: no-cache
cf-ray: 4e943a60bd396f1c-FCO
access-control-allow-origin: *
access-control-request-method: *
expect-ct: max-age=604800, report-uri="https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct"
request-country: IT
request-eu: true
status: 302 Found
vary: Accept-Encoding
via: 1.1 vegur
x-frame-options: ALLOWALL
x-powered-by: Phusion Passenger Enterprise 5.3.7
x-rack-cache: miss
x-request-id: 59f2a72c-9301-4899-bb79-645159ff6774
x-runtime: 0.007197
server: Cloudflare

$ dig drjoshwagner.com

; <<>> DiG 9.10.6 <<>> drjoshwagner.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8537
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;drjoshwagner.com.		IN	A

;; ANSWER SECTION:
drjoshwagner.com.	100	IN	A	104.16.13.194
drjoshwagner.com.	100	IN	A	104.16.14.194
drjoshwagner.com.	100	IN	A	104.16.15.194
drjoshwagner.com.	100	IN	A	104.16.16.194
drjoshwagner.com.	100	IN	A	104.16.12.194

;; Query time: 48 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Wed Jun 19 10:45:55 CEST 2019
;; MSG SIZE  rcvd: 125

what does it mean switch to www host? perhaps use www version instead? there’s no problem for me with that setting. may i know what rules to activate then?

1 Like

It goes through Cloudflare because it points the service provider in question, who happens to use Cloudflare, but it is not proxied for the account in question, hence the page rules will never take effect.

Your www host is already proxied, hence the page rule will apply, you will need to adapt it though, so that it matches the new URL.

Yeah, yeah. Already said so above :slight_smile:

1 Like

Thats what I said originally :wink:

sorry a bit confused. so should i set the domain in CLickfunnels to use the www version?

No, the page rule, the actual user facing domain.

What do you mean by “use”? So that requests for the naked domain get redirected to “www”? If so, you should definitely do that. However on Cloudflare you should focus on your www host, as that is the only one you can proxy and have the page rule actually apply to.

@sandro or @matteo - here is the instruction by Clickfunnels when i added the domain:

and here is my current setting:

is it correct?

however my concern now is create a URL DrJoshWagner.com/freecall that redirects to https://go.oncehub.com/YouDeserveIt