Page rules - Ignore cache not working

Hi,
I’ve created a Page Rule to try and bypass caching for certain pages when the url has nocache=true
In URL i set up mydomain.com/?nocache=true
And in setting, Cache Level -> Bypass
But Cloudflare still caches these URL’s. If I change the file in server i still get the old version (unless i wait a while).
Best regards

Whats the domain and post a screenshot of your page rule list.


Seems to work just fine

When working on a file via ftp for example, if i update it and refresh the page (either f5 and ctrl + f5) i still get the old version.
After a minute (not sure the time) i do get the newer version of the file.
What could it be?

Probably either some caching on your server or your browser cache. Cloudflare properly skips the cache with the configured parameter.

I’ll check other possible causes.
Thank you for helping.

It was opcache that was “delaying” the update.
When i blacklisted the file in question, in /etc/php.d/opcache-default.blacklist, and restarted php-fpm, it updates instantly.

This topic was automatically closed after 14 days. New replies are no longer allowed.