Page Rules Forwarding not working

not working. But I have to wait maybe a couple of minutes. And is the syntax not .*etenslessen.com instead of *etenslessen.com? Or those that not matter? You are awesome sandro.

Enter the exact string as posted earlier and post a screenshot of the page rule.

I could not reply anymore. I had to wait for 24 hours.

That’s not the URL I provided yesterday.

Also, now even the naked domain does not work any more. What else have you changed?

Ah! Thank you that you’re still here. Because I am new I could not reply anymore.

I experimented with the place of the rule (top or bottom) but that broke the naked domain, i think.

Futhermore i only removed the * from etenslessen.com. That’s it.

here is a screenshot of the rules I have. I think that there is the problem because some of the rules (rule 2, 3 and 4) are working

I am sorry: 3, 4 and 5 are working. Rule 2 is also not working. And rule 6 also not.

So you don’t want “www” to redirect? There was a reason why I mentioned you should enter exactly what I wrote :wink:

Also, you have quite a message with your page rules and I would recommend to delete them and set them up from scratch.

I know. You are right. So let me delete the rules that are not working. And build them again.

I will use *etenslessen.com/groepscoaching to forward to Werk met mij - Etenslessen

Right? :slight_smile:

Right, exactly the URL I posted in my previous response.

done. And at top of the rules

Excellent, and now it works again on the naked domain.

It does not work on www, however, and that is probably because that hostname is still with your host. You will need to disable that Cloudflare integration.

okay. Thanks! I still get 404 but if I check with curl -i I see that the forward is indeed working. hmmm. So if I need to disable that Cloudflare integration, how come that other page rules with of without www are working? Like if you use Podcast (redirect to blog) it will forward to Podcasts Etenslessen van Marjena Moll. Also if I use Podcast (redirect to blog), it goes to the right URL Podcasts Etenslessen van Marjena Moll.

And these are rules that are in the Page Rules of Cloudflare.

Thanks for all the help my friend!

Can you run that again?

curl -I http://etenslessen.com/groepscoaching

curl -I http://etenslessen.com/groepscoaching

HTTP/1.1 301 Moved Permanently

Date : Tue, 19 Apr 2022 14:31:36 GMT

Connection : keep-alive

Cache-Control : max-age=3600

Expires : Tue, 19 Apr 2022 15:31:36 GMT

Location : Werk met mij - Etenslessen

Report-To : {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v3?s=%2FHwuHbG7TS4PqpbtQbcQjYbQ1OI006yYm9jpGelpHDbrFKMXk3Ea4x5eGSn%2BQo0aNS8Z9bDatzSjX98GT7fAIN1OaWtqPkySrkKsimz7hYA%2Fz4vjNA%2BbDRQMFUbG0jHBfukthvFu56Mrl1KvnA%3D%3D"}],“group”:“cf-nel”,"max_age”:604800}

NEL : {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}

Server : Cloudflare

CF-RAY : 6fe65844a9594242-AMS

Seems to work just fine.

thanks Sandro! This is great. The naked domain is working and the www. not. I will investigated that further. Awesome.

Check if you have your domain with any provider who has its own Cloudflare integration. In that case the www host might be stuck with their configuration.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.