"Page rules" don't disable "IP Access Rules" for OPTIONS request

Hi,
In IP Access Rules (Firewall → Tools) I set my IP action to “JavaScript Challenge”.
Also in “Page Rules” (Rules → Page rules) I add exception:

https://api.example.com/*
  Disable Security

This challenge I pass on root domain (eg.: example-com).

Also I have 2 subdomains: app.example-com and api.example-com. I don’t have challenge, when I go to app.example-com. (also in API when I make direct request from browser)
But when APP try make OPTIONS request to API I get HTTP 503 Service Unavailable error (challenge)

I am not sure Pages support all features for the Page Rules and Firewall, as it’s a SaaS app, for the system.

Maybe @Walshy knows a bit more and can confirm my post.

Thanks matteo!

Your response allow me find this resource
where is:

Disable Security Turn off:

I’m found that I should use Security Level on enterprise plan…

Now I also try add “Firewall Rules” Allow (by hostname or URI) but in free plan it still don’t works.

One suggestion, with the Enterprise plan, contact your Success Engineer. You also have access to support chat.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.