Page Rules disappeared

We noticed that Page Rules setup as 301 Forwarding URLs have just disappeared, which rendered many of our domains dead for web traffic.

When I search for help, I just find instructions that suggest we need to make sure A records are proxied, which they were at all times (one of the reasons we decided to move our entire domain portfolio to CloudFlare).

When I add BACK the Page Rules, the only way to get them to work is to turn OFF proxied A records? This is the opposite of instructions from CloudFlare.

This doesn’t seem to be limited to 1 host or IP either. This seems to be the case with all of our domains, regardless of where we have A records pointed.

May I ask if you are using some third-party integrator like eZoic or SaaS for your domain(s)?

Kindly, may I suggest you to navigate and look into the Cloudflare account → Audit Log to see more detailed information about what happened.

Correct. To apply the Page Rule, the DNS record (hostname) has to be proxied and set to :orange:

Was it like HTTP to HTTPS or non-www to www, or even vice-versa?
Or rather something else?

Have you got some redirection set at your origin host/server?

May I also ask is “Always Use HTTPS” and/or “Automatic HTTPS Rewrites” option enabled at Cloudflare dashboard → SSL/TLS → Edge Certificates?

Strange a bit.

1 Like

We setup Page Rules as follows:

Rule #1 = https://.olddomain.com/ as Forwarding URL (Status Code: 301) - to https://www.newdomain.com

Rule #2 = http://.olddomain.com/ as Forwarding URL (Status Code: 301) - to https://www.newdomain.com

We are not using any 3rd party integrator/integrations.

Some of our domain registrations are with GoDaddy, some are with CloudFlare now.

Some of our sites are hosted with Liquid Web, some with Digital Ocean, and some with Flywheel. All of these have SSL for the root domain at the host/server.

We stopped using HTACCESS ReWrite rules at the server level because of the Page Rules at the DNS level.

Automatic HTTPS Rewrites are turned on in CloudFlare.

Always Use HTTPS is turned off in CloudFlare.

For whatever reason, all of the above doesn’t work when A records are proxied. This only works when A records are proxied.

Really frustrating!

Can you share the name of the domain and a screenshot of the rules?

1 Like

I need to keep the client confidential.

The Page Rules are as written above. The A record proxy OFF is what’s required to get this to work. I imagine this means that the Page Rule is being bypassed altogether and HTACCESS at the server level is handling the Rewrite.

When I delete the Page Rules, the URL still Rewrites properly.

When I put the A records proxy back ON, the URL still Rewrites properly.

Does this help explain things more clearly? I’m so baffled by this… and I’m sure it will be something simple. Any ideas to help me?