Page rules bug: Browser Cache TTL sends 10 years instead of 30 minutes

cache
page-rules

#1

Hello All!

We are now testing if we can use CloudFlare for our new project, DuzyTV and I think we see page rules bug.

Browser Cache TTL sends users 10 years instead of 30 minutes.

What we need: cache static html files for a while on CloudFlare side (cdn.duzyiod.com domain): we set TTL to 10 years, but clear the cache on CloudFlare side using API when we need to update something. But we need to have 0-30 minutes TTL to send to our users’ browsers.

Example: https://cdn.duzyiod.com/3jxTQRIDpvw.html

We have defined page rule:
cdn.duzyiod.com/*.html
Browser Cache TTL: 30 minutes, Cache Level: Cache Everything

We also tried to add “Edge Cache TTL: a month” with same result: CloudFlare sends 10 years TTL to users.

Please assist.


#2

That sure looks like 10 years. If it’s a bug, open a Support Ticket:
Login to Cloudflare and then contact Cloudflare Support


#3

I’m seeing 30 minutes…

< cf-cache-status: HIT
cf-cache-status: HIT
< cache-control: public, max-age=1800


#4

I should have taken a screenshot. Something that looked cache-related calculated out to 10 years.


#5

We updated our server configuration to set expires to 1800 seconds.
The bug is opened with screenshots of the problem.

cscharff, I you need, I can easily create another simple demo server to demonstrate the problem.


#6

Sure if you don’t mind. I’m technically not in support so my time to troubleshoot is a bit sporadic, but happy to take a look.