Page Rules, Always Use HTTPS not working

Hello there,

I was using a page rule to always use https but that doesn’t when i type my site with http:// it doesn’t use https:// what’s the problem?

Firstly there is no need to use a Page Rule as there is a specific setting in the SSL/TLS section.

What is your domain name?

minilegendary.ga

by the way i have a sub domain i already tried with the ssl settings to turn on full(strict) and it works but on the subdomain forum.minilegendary.ga doesn’t work

The root domain isn’t on Cloudflare. The forum subdomain is, nut the page rules is most likely badly configured.

The simplest solution is to simply use the toggle for the whole domain instead of the page rule.

and how do i do that because its a free domain from freenom.

Obviously in the Cloudflare Dashboard.

thanks