Page rule with Kinsta-always cf-cache control : DYNAMIC

I can’t get the HIT status for the cf-cache control on my homepage.
I use Kinsta as host. Here is my page rule :slight_smile:
https://lb-seniors.fr/*
Auto Minify: HTML, CSS & JS, Browser Cache TTL: an hour, Cache Level: Cache Everything, Edge Cache TTL: 14 days

Does it have to do with Kinsta cache ?
I don’t understand why I can’t get the HIT status!

Even your static files aren’t cached. Can you post a screenshot of your Page Rules? (all of them)

Don’t use Kinsta but your response headers might have clues - specially x-wp-cf-super-cache-cookies-bypass: swfpc-feature-not-enabled - maybe they’re have their own full HTML page cache with bypass cache on cookie via CF Workers and you or they have not yet enabled it?

HTTP/2
200
date: Sun, 11 Apr 2021 02:53:01 GMT
content-type: text/html; charset=UTF-8
cf-ray: 63e0ec144ba04ea3-FRA
cache-control: s-maxage=31536000, max-age=60
content-encoding: gzip
link: <https://lb-seniors.fr/wp-json/>; rel="https://api.w.org/", <https://lb-seniors.fr/wp-json/wp/v2/pages/27>; rel="alternate"; type="application/json", <https://lb-seniors.fr/>; rel=shortlink
vary: Accept-Encoding
cf-cache-status: DYNAMIC
cf-request-id: 096071e0b200004ea36c3c8000000001
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
ki-edge: v=10
x-content-type-options: nosniff
x-edge-location-klb: 1
x-kinsta-cache: HIT
x-wp-cf-super-cache: cache
x-wp-cf-super-cache-active: 1
x-wp-cf-super-cache-cache-control: s-maxage=31536000, max-age=60
x-wp-cf-super-cache-cookies-bypass: swfpc-feature-not-enabled
server: cloudflare
alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400

I didn’t see any cookie activity that would block caching.

Thank you for your answers. Here is a screenshot of my page rule :

I think I am going to try and deactivate the WP super cache plugin.

1 Like

Thank you for your answer. I deactivated the WP cludflare super cache plugin and nothing changed, still got the DYNAMIC status :slight_smile:

  1. alt-svc:

h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400

  1. cf-cache-status:

DYNAMIC

  1. cf-ray:

63e38fec0de75403-LHR

  1. cf-request-id:

096218478700005403a233f000000001

  1. content-encoding:

gzip

  1. content-type:

text/html; charset=UTF-8

  1. date:

Sun, 11 Apr 2021 10:34:24 GMT

  1. expect-ct:

max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct

  1. ki-edge:

v=10

  1. server:

cloudflare

  1. vary:

Accept-Encoding

  1. x-content-type-options:

nosniff

  1. x-edge-location-klb:

1

  1. x-kinsta-cache:

HIT

Something is certainly messed up. Have you asked Kinsta?

1 Like

Yes I asked them. They guide me through resetting the CNAME and A record parameters and then we tried every cache option on the page rule but nothing changed.

Hmmm…Kinsta is pretty tight with Cloudflare. I expected better troubleshooting from them. Next step would be Cloudflare Support. Post the ticket number here, and I’d love to hear what the solution turns out to be.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Actually, I’d expect the opposite. If WP Cloudflare Super Page Cache plugin I assume is this one WP Cloudflare Super Page Cache – WordPress plugin | WordPress.org? Don’t really use this plugin but I did evaluate it for my needs in my Centmin Mod LEMP stack’s Wordpress auto installer for my users.

Actually with WP Cloudflare Super Page Cache plugin, it is used to cache dynamic HTML pages using Cloudflare CDN Cache via either CF Page Speed Rules or via CF Worker based caching using CF Cache Everything rule and implement bypass cache on cookie.

If you disable the plugin, I’d expect dynamic HTML pages to return a DYNAMIC status. Now when you enable the plugin, you probably need to configure settings to enable dynamic HTML caching which you haven’t done so? Plugin would of asked for CF API Token or Key for your domain zone so the plugin can setup CF Page Rule or CF Worker for dynamic HTML caching. I suspect that is what happened if it’s that WP Cloudflare Super Page Cache plugin given the response header returned being x-wp-cf-super-cache-cookies-bypass: swfpc-feature-not-enabled. Which suggests you didn’t enable guest full dynamic HTML page cache with bypass on cookie.

FYI, Cloudflare by default doesn’t cache dynamic HTML unless you use Cache Everything rule, so with plugin disabled it could of removed your CF Page rule? When I did test that plugin, if you disable or remove it, it will auto remove the CF Page Rule or CF Workers it setup for your domain zone - even remove the existing CF Page Rule if it matched the path - so double check if your CF Page Rule is still there.

For plugin support check at [WP Cloudflare Super Page Cache] Support | WordPress.org

2 Likes

Oh just saw your screenshot page rule. Try disabling CF Auto Minify of HTML, CSS, JS and purge CF cache and Kinsta cache and see.

1 Like

Thank you for your advice. I tried clearing Cf cache then Kinsta cache then resetting Page rule only to cache level : cache everything, nothing worked. I think Kinsta cache prevents from using Cloudflare cache

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.

Hi Adrien,

Domain lb-seniors.fr is a managed hostname by Kinsta, so requests for it are actually routed to Kinsta similarly to your CNAME and not to your zone directly. It means that any changes you configure for lb-seniors.fr in your Cloudflare dashboard will not take any effect until Kinsta replicates them in their configuration for your account.

Therefore, in order to resolve this problem, please reach out to Kinsta and ask them to fix their SSL for SaaS configuration for you.