Page Rule wild card not working as expected

I am writing a page rule but having some issues. The rule is*

It works well for: and and and

It does not work for: or

What do I need to do for the * to also allow for / and ? characters?

Can you post a screenshot of that rule?

What you described should work in all mentioned cases.

1 Like

Sorry for the delay. I was on vacation for a week.

Here is a screenshot of the actual rule.

Are you on a partner setup? Or is that an Enterprise-ish CNAME setup?

Seems to work for me however


@sandro thanks for your help on this. This is enterprise. What we are wanting is to not allow the user to see the URL. and does keep the url. But you will see or will serve the url which is not desired. I was assuming the rule of* should catch the / and ? but it is not for some reason.

I would probably take this to the engineer assigned to your account. They should be able to answer that quicklier. Everything Enterprise-ish is sort of a unicorn here :wink: and most people (including myself) have little experience with settings exclusive to that plan level.

The way I interpret your page rule, it should return the “experience” content while keeping the client on “www”. That partially does work, however the cases you mentioned do send a redirect to “experience”. I am afraid I cant tell whether that originates from that page rule (I wouldnt expect it to do so, but then I am not familiar with that particular setting) or whether that might be a redirect from e.g. your server. Have you made sure you can rule out the latter?

This topic was automatically closed after 14 days. New replies are no longer allowed.