Page rule to bypass subdomain doesn't work when using APO

I have a wordpress installation on “example dot com”. Have been using cloudflare for months.
I also have another application at “app dot example dot com”. (sorry they won’t let me post more than 2 links) It has been working fine with cloudflare.

Then I turned on APO for the wordpress on example.com. Really speeds up that site. When I did that, I was immediately unable to login to my app on my subdomain. If you aren’t logged in, it redirects to the login page, and that gets cached so even when you do log in you get redirected to the login page.

So I thought I could put this page rule, app.example.com/* set to bypass. But it doesn’t work. When I go into DNS settings and toggle the proxy/bypass setting for the subdomain I can get my application to work, but then I’m exposing my IP. So I know the issue is some caching, the subdomain works fine when I bypass cloudflare completely for the subdomain. But the page rule fails when I proxy that subdomain. And this all started right after setting up APO on primary domain.

How to not cache the subdomain without exposing my IP? And why is it suddenly an issue after setting up APO?

If you go to Speed → Optimization, does it show APO only applying to the main domain?

It shows example.com and www.example.com. on that page it doesn’t list my subdomain

Without knowing the actual domain, we can’t really check on it. But if you create a ticket and post it here, @yevgen will probably take a look at it.

To contact Cloudflare Customer Support, login & go to Cloudflare | Web Performance & Security and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

Please create support ticket and post # in the thread (to speed up response time) so we can help you.

1 Like

thanks @yevgen it’s # 2079139

@yevgen bummer it looks like they don’t understand my issue. The wordpress site it fine, it’s my other application on the subdomain that isn’t working. I said this happened when I enabled APO so they’re stuck thinking about the wordpress site.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.