Page rule still effective even after being deleted

pagerules

#1

I had issues with an SSL cert so created a page rule to redirect all traffic to the non ssl URL so had no downtime but I’ve now sorted the SSL cert and deleted the rule yet it still tried to redirect to a SSL URL so getting stuck in a loop as the server is trying to do the opposite.

Has anybody else experienced this? If so, how’d you get past it?


#2

How did you configure the redirect? There is a chance your browser still caches it. Have you tried it with other browsers/machines?


#3

Set it up as a temporary redirect and isn’t cached on my local machine but seems to be through CloudFlare; if I change the DNS record to be DNS only it works, as soon as I enabled DNS and CDN through CloudFlare it breaks.


#4

Maybe also try to purge Cloudflare’s cache. I wouldnt expect it to have an effect here, but cant rule it out either. Can you share the URL here?


#5

Cleared cache and enabled the records through CloudFlare and breaks instantly; as it’s a live website I can’t leave it offline for long.


#7

Right now it does not go via Cloudflare, so its difficult to test what the issue is.


#8

Sending a request through Cloudflare with your domain returns the following response

HTTP/1.1 301 Moved Permanently
Date: Tue, 04 Sep 2018 16:55:25 GMT
Content-Type: text/html
Transfer-Encoding: chunked
Connection: keep-alive
Set-Cookie: <-------->; expires=Wed, 04-Sep-19 16:55:25 GMT; path=/; domain=.molearchitects.co.uk; HttpOnly
Location: https://www.molearchitects.co.uk/
Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Server: cloudflare
CF-RAY: <------->

102
<html>
<head><title>301 Moved Permanently</title><script src="/cdn-cgi/apps/head/eanNMiNcihKxXJ49YbtQwinTous.js"></script></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx/1.15.0</center>
</body>
</html>

0

Considering the redirect HTML shows the same nginx version as your server I would assume it does come from your server. However a request directly to your server does return a proper 200. Are you sure your Cloudflare configuration does point to the same server? So basically, when you disabled Cloudflare have you just switched :orange: to :grey: or have you changed something else DNS-wise as well?


#9

Yeah I’ve had to turn :orange: to :grey: as it gets stuck in a redirect loop.

I can’t leave the :orange: on as it’s a live website so need to minimise downtime.


#10

I understand that, but in that way it is somewhat impossible to debug.

“Somewhat” as you can still try to send the request through Cloudflare - as I did above - but I cant guarantee the behaviour is the same.

Considering the earlier reply it would seem as if the 301 comes from your server, even though hitting it directly does not issue it. So basically you only change the proxying status and nothing else?

Looks a bit mysterious at this point, my next step would be probably to activate proxying and check in the log files if the “looping” request actually goes through to my server.


#11

Tested again this morning and it looks like the redirect when turning on :orange: had been cached; which has now resolved itself.

Didn’t realise CloudFlare cached temporary redirects so much but learn something new everyday.


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.