Page rule redirect http to https

I have a A Record pointing to webserver. The DNS record is not proxied thru cloudflare.
Currently these pages gets redirection working perfectly via page Rule Forwarding URL >> redirects to >> >> redirects to >> Does NOT redirect to

Any ideas? #general

In that case page rules wont run.

I also thought so but page rules are working perfectly.

They cant on a non-proxied host. On “www” they run because it is proxied.

Please see the rules. Now i have turned OFF all above rules

Noe these dont work

Again, the rules will only work for “www”. Also, rule #2 and #3 will never run as the request will always be caught by rule #1.

If you just want an HTTPS redirect you dont even need a rule, just use the global Always-use-HTTPS setting.

Sandro sorry to trouble you.

i have enabled Always Use HTTPS but am not able to turn ON proxy as its creating a conflict with another firewall am using.

Is there a way to to https

If you cant proxy you can perform that redirect only directly on your server.

1 Like

Thanks you Sandro for your advice this issue is not solved at server side.

Can you tell me if there is any issue with connectivity to Firewall Sophos UTM 9 on hosted on AWS. Traffic to the website goes thru sophos.

Currently traffic is not proxied thru cloudflare. The moment i enable it website goes down. So have turned off for now. Any ideas on this topic? Is there any ip i need to whitelist in sophos firewall?

The previous advice still applies. Your naked domain is not proxied and hence the page rule wont fire. You either need to proxy it or handle the redirect on your server.

As for going down, that is most likely because you seem to have - the highly discouraged - Flexible mode set. Switch that to “Full strict” and the redirection loop should get fixed.

Here is what the issue, I would like to activate traffic via proxy, Issue is when i turn on CF proxy website stops working

This topic was automatically closed after 14 days. New replies are no longer allowed.