Page rule not working (disable SSL)


#1

I created a page rule to disable SSL for a single URL, which is used to publish blog posts from Open Live Writer (since it doesn’t work with SSL, at least not with the Joomla XMLRPC plugin).

Publishing works fine when Always use HTTPS is OFF. But when I turn it back on, publishing fails, so this tells me the page rule is failing. I’ve verified the URL in the rule matches the URL being used for the connection attempt. I’d appreciate any insights about this or suggestions.


#2

I believe “Always Use HTTPS” will kick in before page rules take effect. Turn it off on Crypto, then tweak your page rules as follows:

If you put your Open Live rule page rule first that sets your SSL (off), and a followup page rule to enable Always Use HTTP and SSL Full(Strict?), that should work.


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.