Page Rule not apllying SSL on some hits

Hey,

We have Klaviyo dedicated click tracking set up through Cloudflare using the default settings using Page Rules with full SSL to the trk subdomain. Some hits are getting unsecure page alerts. Not sure why this is happening and struggling to recreate the issue.

If anyone has any idea where I need to start troubleshooting that would be great.

Thanks,
Ruan

That’s an insecure setting to begin with, I am afraid. I’d change that first to Full Strict.

Your screenshot unfortunately suggests that your server may not be properly configured, so I’d pause Cloudflare to make sure everything loads fine on HTTPS, contact the host if it doesn’t, and once everything was fixed, you can enable Cloudflare again.

1 Like

Hi Sandro,

Thanks for the reply. I went on recommendation from the link below,

(https://help.klaviyo.com/hc/en-us/articles/360052205052-How-to-set-up-SSL-for-dedicated-click-tracking)

Should I rather be using strict? Would it affect the click tracking in any way?

Thanks,

Unfortunately that is a rather disastrous advice on their side, as they are telling you to disable all security on your site.

As it is not clear what else may be breaking, I would really check the whole site setup first and pause Cloudflare for now - Pause Cloudflare · Cloudflare Fundamentals docs - and make sure that everything loads fine on HTTPS first.

1 Like

If your click tracking works on Full, it will also work on Full (strict). You just need to make sure you have a valid SSL certificate installed on your origin server.

As Sandro already mentioned, the best way to do this is to pause Cloudflare and fix the issue. Once your site loads over HTTPS without issues you can unpause Cloudflare.

2 Likes

99% of the time the clicks do hit the site with https. I have just gotten another complaint this morning so I am trying to investigate.

I have a case open on the Klaviyo side so will ask them too. Thank you for all the advice. Appreciate it.

Steps I would suggest

  • Switch to Full Strict
  • Pause Cloudflare
  • Verify your site is loading fine on HTTPS
  • Once everything works, you can enable Cloudflare again

If you want you can also post the domain.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.