Page rule isn't working

I see that if I go to HTTP of my site instead of HTTPS I get a block because I block all HTTP/1.1 requests. All fine and well and that’s exactly how it should work. So to remedy this I created a page rule for a 301 permanent redirect to redirect all HTTP requests to the HTTPS site. Still I was blocked. Here’s what that rule looks like:

http://toddexler.com/*

Forwarding rule permanent 301 redirect

https://toddexler.com/$1

Now I tried something else where I pulled the wild card and doing that CloudFlare’s edge threw an error! So I put the wild card back.

It’s looking like the firewall kicks in before the page rule. Or am I doing something wrong?

That sure looks like the Always Use HTTPS feature from the SSL/TLS Edge Certificates section. That option didn’t take care of this for you?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.