Page rule forward URL not working

I’ve configured a proxied CNAME and I’d like to forward all URLs to the base domain. However the redirect isn’t working. It’s just going to the current server instead.

Here is my CNAME record. I know it’s correct because if I delete it or change it to a non-proxied URL then it works.

Type: CNAME
Name: blog
Target: procad.ie
TTL: auto
Proxy status: Proxied

There’s also an A record for the root domain pointing to the server IP.

And here’s the page forward.

Many thanks!

Which nameservers are mentioned on your DNS screen?

Also, can you post a screenshot of your page rule list?

These are the nameservers:

algin.ns.cloudflare.com
aron.ns.cloudflare.com

And the only page rule is the on in the OP

Thanks!

These should be the correct nameservers.

Did you have the domain previously with some other provider who might have applied their own Cloudflare integration? If so, some of your domain configuration could be still stuck there and override your own here.

No sorry I don’t think so. I’ll forward the response on to the client though. It’s just very frustrating.

In that case you can only open a support ticket and ask them to clarify why the page rule does not fire even though the configuration should be correct.

They will try to push you back to the community but if that is an issue with Cloudflare - as it seems - that’s something only they can fix and point that out and feel free to refer to this thread as well.

@MoreHelp i can’t get through this and support isn’t really helping if I can’t get help then I need to just not use the proxy but that’s a whole lot of extra stuff I’d rather not do.

As I already said three days ago

You’ll need to push support for that.

Thank you sandro but I already have pushed them and I only receive automated responses. They advised:

  1. If you don’t receive a reply within 72 hours of asking the Community, reply to your own Community post and at mention @MoreHelp to bring your post to our attention.

So tagging an employee here is probably my last hope and at this point I’m just going to move on to using a non-proxied CNAME record and do the redirect directly on the server.

That’s what I also predicted :wink:

They do occasionally show up for a couple of hours and I will tag them at that point, but I am afraid until then you’ll really have to wait or unproxy. Whatever is stuck can only be fixed by someone with direct access to the system and nobody here expect Cloudflare staff has that.

Thank you sandro and I do appreciate your trying to help.

I also recognise I’m not on a paid plan so I can’t expect much from CF support but still…

Yeah, Cloudflare has essentially outsourced support for non-paid plans to the forum but hasn’t taken into account what happens with cases where the community can’t fix it.

In your case we can only analyse the issue, but support will have to push the right buttons.

Whenever a support member shows up, I’ll tag them and they can hopefully “unstuck” your domain.

I had a similar problem pointing from an old domain to a new sub domain. I did edit the A record in the DNS (pointing to the new IP). Then I edited the Nginx default settings (probably about the same for Apache). Works perfect for me:

server {
  server_name gowebstatic.tk;
  return 301 http://static.go4webdev.org$request_uri;
}

That’s not related to Cloudflare or page rules, that’s just a local redirect on the origin.

Yes, I know. But the result was the desired. Problem solved. :slight_smile:

Sure, but you can do most of the Cloudflare “things” on the origin and I assume the OP is aware of that. The issue is about the page rule which does not fire and, assuming the configuration is broken right now, support will generally have to look into this and fix it, as I guess there’ll be more things which won’t work.

1 Like

@r.mcnamara, can you also post the ticket number for later reference?

Good call! Ticket ID: 2206327

All right, I’d assume at least one will show up today, will let them know and I guess getting your account unstuck should be fairly easy. You possibly might have to confirm something in the ticket.

Thanks! In the mean time I’ve requested admin access to the server so one way or the other I’ll get this sorted today. :grin: