Page Rule for SSL when Always Redirect is not on


#1

I have seen in other posts that the check for always redirect happens before page rules and therefore page rules won’t work. I don’t use always redirect. Can I use Page Rule to solve this problem? Basically, SSL is working properly with my Facebook app, but phpMyAdmin at https://subdomain.domain.com:8080/phpmyadmin is not working. Will disabling SSL via Page Rule fix it? Either it is not fixing it or I have it wrong. Thanks!

“ERR_SSL_PROTOCOL_ERROR”


#2

8080 isn’t a port we treat as https.


#3

I understand that. Can I disable the CloudFlare handling for phpMyAdmin? I have a SSL certificate setup for that.


#4

As long as Cloudflare is proxying a request we’re going to present or not an SSL certificate for an https request as we’re an SSL termination endpoint. You could have the admin listen on another port which supports SSL or not proxy that subdomain through Cloudflare.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.