Page rule fails

I have a free account. I set up 3 page rules. They worked for a while then ‘SSL’ and ‘Always use HTTPS’ stopped. I tried to edit them but failed, so deleted them with the intention of setting them up again. Now I can’t add them again because I get error code 1004. I’ve logged off and on again but no success. Image attached to show situation. I can’t upload a second as I’m too new to this community. It would have showed my Page Rule page state I have two rules left.

Until the current Config issue clears up, I’d leave things alone. Judging from the blue message, the Page Rules sections seems to be confused.

OK, thanks for speedy reply. I’ll wait a couple of days but really want my site to show it is secure. By replying I hope it gives me the opportunity to upload the second image.

Just curious to know how this issue is progressing? I still can’t set up page rules.

If it’s still not working, open up a support ticket:
Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

Thank you for this. As a free account holder, I did not think I was entitled to raise tickets but could only use the forum.

I have now raised a ticket with attachments showing the error messages and the fact that I have two rules unused.

Unfortunately Cloudflare have said they have unprecedented demand and I should raise my issue with the community. So I’m back to square one.
Thanks again for helping me.

Can you please post the ticket #? It’s not a dead issue to them…they’ll respond. If you get an automated response, reply back that you’ve tried the suggestions and it’s not working. And then a human should pick it up from there.

Great you are still taking an interest.
The ticket number is 1812496.
I replied to the bot saying I had already tried the community and was advised to raise a ticket so, as a Free user, hope they will eventually deal with all the paying customers and get down to looking at my issue.

1 Like

Let’s see if @cloonan has seen this one.

1 Like

I see it and added myself and link to this conversation. Will keep an eye out.

While we’re waiting for Support, is the goal to ensure the site loads with https? If so, on the SSL/TLS app, edge certificate tab, can you turn on Always use https? WRT the page rule, I think the reason you cannot create a second is it’s the same as the first rule.

But, that rule is not active and it does not affect security…:confused: as to the goal of that rule…

1 Like

Hi cloonan,
I’ve now turned on Always Use HTTPS on the Edge Certificates tab. I hadn’t done this before because I had not realised the implications and opportunities that tab offered.

I had read as much of the help stuff as I thought necessary to achieve what I wanted but for someone unfamiliar with virtually everything on offer, I was overwhelmed with all the info.

When I saw it is possible to setup ‘Using SSL’ as a page rule, I activated that and thought it was job done.

When I got the error messages, I didn’t know what to do except ask the community.
.
I don’t see how ‘Using SSL’ is the same as the one page rule I do have setup called ‘Always Online’. Are they really the same?

You are correct, Always online is different than Always use https, https://support.cloudflare.com/hc/en-us/sections/200820388-Always-Online versus https://support.cloudflare.com/hc/en-us/articles/204144518-SSL-FAQ.

Based on the screen shot of the error, it looked like the target URL for the rule you have and the rule you’re attempting to add are the same. Can you share the If the URL matches: section above Then the settings are:? This is a similar ask as the one the engineer just asked on the ticket, “which settings you were using for the page rules and the URL values you entered?”

To address the question of the difference between page rules Always use HTTPS and SSL. If that question is WRT the various options in the Then the settings are: section, if you select SSL you have the ability to switch the SSL mode for url(s) that match the pattern you specify. This is versus if you select Always use HTTPS. In that case, the matching urls will load with whatever SSL setting you have on the overview tab of the ssl/tls app and the page will load https://example.com even if users enter http://example.com or example.com.

Hi
I mistakenly wrote ‘I don’t see how ‘Using SSL’ is the same as the one page rule I do have setup called ‘Always Online’. Are they really the same?’ in error. ‘Always Online’ was wrong.

Maybe a better question is ‘What is the difference between SSL and Always Use HTTPS’. I did a search on the community page for Always Use HTTPS and the best answer heading was SSL FAQ so that reinforces my question as to why both exist as rules when hey seem to be the same.

In fact the engineer’s reply covers this point so please ignore my further question.

As for your request to show a screen print of the If the URL matches: section above Then the settings are: ? I think I now realise I can only have one rule per url and was misled by have 3 free rules and so being able to set up 3 on the one domain.