Page rule doesn't working

My website, hosted on opensrs, is responding on [https://www.blossomforu.com ]

I added a page rule to forward the root domain to www, but it is not working. Why?

DNS record:

Name Servers:

1 Like

Works for me. I expect it’s just a caching issue on your end. Try a different browser/device/network.

Note that the www subdomain is not proxied. So you are going directly to the origin, without using Cloudflare’s services.

1 Like

I want the root domain [http://blossomforu.com] can redirect to subdomain [https://www.blossomforu.com] , but still not working.

And the root domain [http://blossomforu.com] will show this page:

but right page is [https://www.blossomforu.com]

Can you help me check the root domain’s redirect?

I have set the A record

and page rule:

but I check the root domain [http://blossomforu.com] still redirect to this wrong page:

and the correct page is [https://www.blossomforu.com]

I have no idea why the 301 URL redirect page rule is not working

Is this a wordpress site ?

no, the root domain will go to easystore 's page.

but we need the correct page will into [www.blossomforu.com], is shopline site

Can you access the file manager of easystore page ?

no, I can’t access the file manager of easystore page.

but easystore says they have taken the domain down.

There is no easystore TXT record in my Cloudflare account.

the situation pretty bizarre :sob:

So , that’s the Issue add the TXT Record of easystore page in Cloudflare , Then Revert back

But I have not used easystore now, I change to NEW Ecommerce Platform.

https://www.blossomforu.com is my new website (Don’t use easystore)

so I want https://blossomforu.com redirect to https://www.blossomforu.com

I set the DNS records according to the tutorial but it didn’t work

I have added a page rule to forward the root domain (blossomforu.com) to https://www.blossomforu.com, but it is not working, how can I fix this problem?

Hi, it looks like your website isn’t proxied by Cloudflare which is why the page rule isn’t working, make sure your A records are :orange: in your DNS settings on the Cloudflare Dashboard

1 Like

But the A record in blossomforu.com has already proxied

@soldier_21 @matteo sorry our page rule still not working
we have checked the A record has already proxied.
Could you guys know there have other reasion will make page rule not workin :sob:

In the last 6 months your domain has been on three different Cloudflare accounts. Were you ever on a Partner or SaaS setup, such as with providers like Shopify? These will interfere in you using your own Page Rules.

2 Likes

hi @soldier_21 @matteo @michael @Neeraj_1

After our root domain opens the proxy, it will be proxyed to the non-root cname URL. And the page rule can’t working.

We cleared all caches, and sttill have the same problem.

We want to confirm whether the proxy of Cloudflare has a cache or is still on the easystore side?

I am Sorry @emilyliu , But I Really have No Idea about this !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.