Page rule does not apply

Hi,

I hope you guys have encountered this one and can help me. I tried CF support but they seem to be useless, from the answers i got i am not even sure if they know how to read, they sure don’t read what i write. Anyway…

I have set up this page rule to redirect the root domain to www , but it never gets triggered. Have i configured it wrong ?

What is even stranger is that the root domain does not proxy my origin. If i use the www it works perfectly and proxies to origin. Same configuration on both of them ( same IP and same origin config

  • nginx ).

Tried to delete the domain and add it again but it seems CF keeps the configurations, doesn’t really delete it.

Hello there,

It is proxying as I see & according to this:

The issue is: It’s a 404 error call. As the message says: There’s no page found for the same. Would you ensure that at first.

@neiljay i did not say it is nor proxied, if you read carefully you can see i said : What is even stranger is that the root domain does not proxy **my origin**.

The domain is proxied through Cloudflare just it is not going to my origin. I have no requests on the origin server.

But lets say that is a secondary problem to the main one , the page rules.

I’m afraid you need to fix what you call the secondary problem.

You are mistaken, if you look at the Traffic sequence page rules comes third , it doesn’t matter what the origin response is. Tested multiple times.

And again there is nothing to do with the origin as it is not called by Cloudflare anyway.

For me it did work this way:

Use 301 permanent redirect instead of temporary redirect. Deploy & refresh. Check in a different browser.

Tried it, no joy.

It should work. Would you give it a try this way?
After creating the rule, refresh the page
Try clearing browser cache files.
Try using different browser
Try using incognito mode

Saying it should work doesn’t change the reallity.

It does not.

However a possible answer came from support, it was not very clear but from what i can understand is that someone else also added the domain in their Cloudflare account… but i do not see how they could have done that… And how can i regain full control of it.

Could you temporary determine if this behaviour continues by using a “Pause” option at Cloudfalre as follows?:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

Have you used eZoic before?

Hi,
I just did use the pause option and the origin works as expected, loading the website. Ofc it has a self sign certificate.

No idea what eZoic is…

So, for those who may come other this issue you should know the reason this appeared is because i tried to add the domain to https://render.com/ . Because it was not what i was looking for i decided not to go on that route however i did not remove from their system the custom domain setting, i just changed the cname from my root pointing to something else. It seems that render also uses Cloudflare and their SaaS settings supersede your own account control .

P.S. I love all CF products but I really hope you never have to contact CF support , it is horrible!