Page rule cache level cache everything .html

I set up a page rule to cache all my .html pages, but when I try to change the currency in any of these pages, the system does not change it.

Use Prestashop 1.6

Thankful for your comments


Have you tried going to the Cloudflare Cache page to Purge Everything?

No, I’ll see how it goes

Still the same. I purge the entire CF cache, then apply the page rule, which caches all the .html pages, and when trying to change the currency in any of those pages it does not. If you can try, my website is and visit a product and try to change the modena in the upper left.

For the error to occur, cf-cache-status must be HIT

I’m not seeing a Cache Status for the home page or the men’s perfumes page. And the prices are updating.

I think because the URL is the same, your Page Cache is going to catch whatever currency the first visitor chooses. You may have to turn off that Cache Everything.

On the homepage and in the categories I do not have the cache enabled, I only enabled the products to try. Since the url of the products have .html at the end.

From what you say in the previous message, it is correct. When changing the currency the url remains the same.

Any idea to make this work?

No, it’s one of the limitations of caching. Any dynamic page that shows different content for different users can not be cached. Shopping sites are especially tricky because you don’t want to mix up shopping carts.

Thank you for your comments


Sorry, and what could I apply to speed up my ecommerce?

The slowest part looks to be page generation. I don’t know how to speed up Prestashop…other than a faster server/database. Here’s an article that has a handful of tips:

1 Like

Thank you so much for your advice.

I already read that article, but thanks again.

Touch to read more.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.