Page Rule Cache Everything is not working if SSL/STL is at full strict

Hi Everyone,

Can you please help me or give me an idea on how to solve my problem with page rule? recently I set a page rule cache level everything and bypass wp-login and wp-admin using the following rules:

https://sample.net/2020/*
Cache Level: Cache Everything

https://sample.net/2019/*
Cache Level: Cache Everything

https://sample.net/2020/*
Cache Level: Cache Everything

https://sample.net/wp-login.php
Cache Level: Bypass

https://sample.net/wp-admin/
Cache Level: Bypass

The problem is when I am trying to test the page URL’s to CF-Cache-Status it is not hitting. Then when I tried to change my encryption from full strict to flexible, it works, it hits, the problem is my site is down when the encryption is inflexible.

I contacted my hosting support and they said that it is not advisable to change my encryption from fullstrict to flexible. Any suggestions or advice on how I can make this work?

I also set the DNS cloud :orange: for the domain/subdomain that I want to trigger, but nothing happens

Thanks.

They are absolutely right. Flexible should never be selected, it is a broken setting.

You need to make sure you have a valid certificate on your server. Your host should be able to assist you there, respectively you can get a certificate from Lets Encrypt or also an Origin certificate from Cloudflare.

This topic was automatically closed after 14 days. New replies are no longer allowed.