Page not caching. 503 Error

I’m setting up a woo commerce site with just enough experience to get in trouble. Please provide detailed help especially on where to find things.

I go into the analytic tab and get a 503 error.

When I test the cache out it says:

Page caching seems not working for both dynamic and static pages.

Error on dynamic page (https://theresustailor.com): Invalid Cache-Control response header. If you are using Litespeed Server, please disable the option Overwrite the cache-control header for WordPress’s pages using web server rules , purge the cache and retry.

Error on static resource (This is a Test Page): Cache status: BYPASS - Cloudflare has been instructed to not cache this asset. It has been served directly from the origin.

Please check if the page caching is working by yourself by surfing the website in incognito mode 'cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT , the page caching is working well.

I’m running Autoptomize, I’ve disabled the plugin and the error persist.

Thanks!

You’re setting cookies, so Cloudflare won’t cache the page, as cookies are generally used to identify unique visitors.

The cookies I see from ‘curl’ are incap_sesXXX and visid_incapXXX

But in a browser, I end up getting consistent cache HITs after a few reloads.

Your testcache page also returns a HIT.

So, in real world use, it looks like everything is working.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.