Page loading without https

I have done all the necessary steps to complete the SSL setup.
But unfortunately after selecting “Always Use HTTPS” - ON than also my website `pickatime.in is loading without https. please help.

The website loads with HTTPS for me, but gives a 522 error:

Could you tell us who your host is, and what the SSL mode is (from https://dash.cloudflare.com/?zone=ssl-tls)?

I have my won hosting server. If i simply type in the URL bar “pickatime.in” it’s working. But in case if I type “https://www.pickatime.in” than it doesn’t work.

Neither URL works for me, both time out.

Your computer or router might ave a cached DNS response showing the old IP. the Cloudflare IP currently shows up in DNS: https://dns.google/query?name=pickatime.in&type=A&dnssec=true

Could you post what the SSL/TLS overview page shows?

image

I have tried all the setting in my router and restarted full network.
Not able to find out where is the problem.
Moreover for you URL time out whereas in my side URL is opening without https://

Plz any one help me…

Your site actually started to work for me.

Could you run the following command in a windows command prompt and screenshot the output?

nslookup www.pickatime.in 

Somewhere on your network has cached the DNS results. It might even be your ISP. See the following link, it resolves to a Cloudflare IP (104...) everywhere else in the world https://www.whatsmydns.net/#A/www.pickatime.in

Thank you for your time.
What is your suggestion to come out from this situation.
I am totally new in cloudflare don’t have much experience. I just wanted to start/add SSL through Cloudflare but unable to process.

The last thing I can recommend is loading from an incognito window in Chrome or trying it on a mobile network, your ISP might have aggressive caching to lower their costs of running DNS.

Also maybe try setting up 1.1.1.1 on your computer, that might invalidate the cache:

https://1.1.1.1/dns/#setup-instructions

But I can report it will redirect http->https on my connection

image

Is it opening with https:// in your computer?