Page loading error: Everything's working on our side, so the link you clicked is either wrong or has been retired

I just recently moved my domain from GoDaddy to CouldFlare. I have SSL/TLS enabled to “full”.
I setup a page rule for domain name forwarding. It’s set to
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: Sanchay Javeria)

However, when I go to, I see this:

How do I resolve this error?

Do you want to forward everything to that Github URL?

Plus, your encryption mode should be “Full Strict”.

Currently is redirecting to, if that’s what do you want, well done.
If not, please explain what do you want to do with your domain exactly. :grin:

(If you notice something that seems wrong, make sure you clear/purge your cache either in your browser and cloudflare because it could be just cached.)

Hey @albertcf, I want to forward everything to Sanchay Javeria with domain masking enabled. GoDaddy lets me do that but I don’t how I can do that on Cloudflare.

Currently, I’m not able to access at all. I ran cloudflare diagnostics on it and it says the same thing: Diagnostic Center | Check SSL and Test Website Security | Cloudflare

I cleared my browser cache and I still see the image attached with my question. Do you know how I can resolve it?

@sandro Yes, I want to forward it to that github URL with domain masking enabled.

In that case you should follow the following steps.

  1. Change your encryption mode to Full Strict
  2. Remove the current page rule
  3. Set up the following new page rule (<- link)

@sandro it’s working now :smiley: thanks!

Does Cloudflare provide web hosting as well? I would like to move away from Github so that I don’t have to setup redirects like this.

I am afraid Cloudflare does not offer hosting, apart from rather specialised services such as Worker Sites and Pages, but those are not traditional hosting.

To deploy websites, check out Cloudflare Pages. You can create a project from a GitHub repository (React, Svelte, Nextjs etc…)

Thanks @albertcf, this is great. As an alternative, I was able to get rid of page redirects by adding new CNAME records pointing to the github pages and adding a custom domain in the github pages’ settings. The steps are detailed on github here: Managing a custom domain for your GitHub Pages site - GitHub Docs

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.