'Page Isn't Redirecting Properly'


I hope someone can help me with a problem I have. Every time I activate Cloudflare I get the ‘page isn’t redirecting properly’ error/screen when I load my domain. I have read similar topics on this here but can’t find a solution which applies to me.

The https version of my site is setup in wordpress general settings.

I’m using really Simple SSL wordpress plugin to redirect everything.

My SSL certificate is from Hostgator not Cloudflare, and I have SSL turned off in Cloudflare.

My domain is - https://aeonreviews.com/

Cloudflare is currently paused but I can unpause if needed to help with error.

Any suggestions would be appreciate, thanks.

1 Like

Is your SSL setting here Full (Strict)?

It sounds like you have it set to Flexible, so Cloudflare uses HTTP to reach your site, but your site redirects to HTTPS, and the cycle repeats.


Hi, SSL is turned off in Cloudflare as I have SSL already, I turned it off as I figured it would cause conflicts. Are you suggesting it needs to be set to full/strict? I’m hesitant to do this as I have a paid SSL on the site already and don’t want to replace it.

Sorry, I missed the part about how you had SSL turned off in Cloudflare.

Cloudflare is a Proxy server, so visitors hit Clouflare’s proxy server in order to visit your site. You’ve set SSL to off, so Cloudflare will operate in HTTP-Only mode. Now it’s going to try to reach your site with HTTP, but your site redirects to HTTPS, just like in the “Flexible SSL” scenario.

So…set your Cloudflare SSL to Full (Strict) because you have a valid SSL certificate on your server. And Cloudflare will present visitors with the SSL certificate for the Cloudflare proxy server.


Thanks I’ll give it a try, sounds like my SSL certificate is redundant then if visitors are being served with the Cloudflare SSL certificate if I’ve understood you correctly?

It’s not redundant. Cloudflare will use that when connecting to your server securely.

1 Like

Ok thanks

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.