Page functions has issues with double slash

I created a “Pages” application running from an anguler project. I have functions setup to reverse-proxy traffic to the /blog path to my wordpress server. I simply created a worker in the following path on the angular project: ‘/functions/blog/[[catchall]].js’.

Traffic is proxied as expected to the blog. But, when the URL path contains 2 consecutive forward slash characters (like for example https://www.example.com/blog/wp-admin//options.php), the request is sent to the angular application, and not to the reverse-proxy worker. Do you know why that is, and how I could fix that?

My Worpdress site is adding an extra forward slash in some rare instances, I didn’t manage to find why, but it should be fine and properly routed to the server.

Thank you for your help.