Page forwarding rule

Hello friends,
I’ve updated the name server on GoDaddy for my site. When I go to www.highcountrypropane.com, the page forwarding rule properly redirects. When I go to highcountrypropane.com, it does not. I updated the nameserver on Monday. Do I need to wait more time? Another site I did on Monday is working without an issue.

Thanks!

Did you set up a Redirect Rule or Page Rule that covers highcountrypropane.com (as there doesn’t seem to be one) as well as www.highcountrypropane.com? Can you show a screenshot of it?

curl -I https://highcountrypropane.com/
HTTP/2 200
date: Wed, 01 May 2024 16:42:09 GMT
content-type: text/html; charset=UTF-8
vary: Accept-Encoding
vary: Accept-Encoding
vary: Accept-Encoding
vary: Accept-Encoding,Cookie
x-powered-by: WP Engine
link: <https://highcountrypropane.com/wp-json/>; rel="https://api.w.org/"
link: <https://highcountrypropane.com/wp-json/wp/v2/pages/842>; rel="alternate"; type="application/json"
link: <https://highcountrypropane.com/>; rel=shortlink
x-cacheable: SHORT
cache-control: max-age=600, must-revalidate
x-cache: HIT: 4
x-cache-group: normal
cf-cache-status: DYNAMIC
set-cookie: __cf_bm=WZcGeHu2.ybjEees..3IPxJW8mHFqIOyIBrm.wcp4Z4-1714581729-1.0.1.1-fMlCtgKJlAO85uJxArIM7i0TUINoEShN5CMm.mF1H9kVn0gjrvPCosz7AD6NXZxNhAC0PhYsU4GylB0U2zFo2w; path=/; expires=Wed, 01-May-24 17:12:09 GMT; domain=.highcountrypropane.com; HttpOnly; Secure; SameSite=None
server: cloudflare
cf-ray: 87d1391dfc81418b-LHR
alt-svc: h3=":443"; ma=86400

curl -I https://www.highcountrypropane.com/
HTTP/2 301
date: Wed, 01 May 2024 16:42:12 GMT
content-type: text/html
content-length: 167
location: https://superiorpluspropane.com/high-country/
cache-control: max-age=3600
expires: Wed, 01 May 2024 17:42:12 GMT
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v4?s=06eS0JkYh3UvIUAmajbhxMGRO%2Ft9bEUV%2BLpky2xm80krfu2WC3bymONG4EyqHcEzyfDbpjQknFgjaruGWxcb1llrKLwW7vH0a2jDa6E0y1Zi4EWOu%2Fen%2BmdiNd9x%2FI9ZSFDhh4ZDzmVtplp%2F4%2BwnHUzchDfnNienYA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 87d13936d83e6402-LHR
alt-svc: h3=":443"; ma=86400

Thanks for the response!

I’m proxying the A record and the CNAME record for the site, as it’s still living with GoDaddy. The page rule I have in place is:

highcountrypropane.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://superiorpluspropane.com/high-country/)

Make sure the Page Rule hasn’t accidentally been switched off.

What is the value of the A record that is being proxied?

Yes, unfortunately it’s continued to be enabled. And there are two, both pointing to WPEngine Inc. IPs. I’ve proxied both on Cloudflare.

WPEngine uses Cloudflare, seems redirects don’t work (are ignored?) if the DNS records point to Cloudflare IPs.

Assuming the domain is being redirected in full, try replacing the WPEngine IPs with proxied dummy values of A 192.0.2.1 or AAAA 100::.

1 Like

Perfect, that fixed it. Thank you for all the information!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.