Page changes not updating erratic-ness, lag on initial loading

After making changes in Wordpress using Elementor, those changes are not reflected everywhere. Without getting too into the weeds about where I can see my changes, and where I cant, I think the most poignant example of where the changes SHOULD be reflecting, but aren’t, is in Pagespeed Insights.

Pagespeed shows an old version of my website. The ONLY way I can get Pagespeed Insights (or other page speed sites) to update my website changes is to change name servers to Godaddy, and then back to Cloudflare.

I have tried “purge everything”. I have tried developers mode. I have tried pausing cloudflare. I have tried turning page vcaching rules on and off.

There is very odd behavior when browsing regular vs incognito and desktop vs mobile, but little consistency so I dont want to derail the question.

I can turn attack mode on, which will work, and then display the newest version of my site when I solve the captcha, but if I turn attack mode off, the same browser will revert back to showing the old version of my site. Attack mode also does not seem to affect Pagespeed, I would imagine it shouldn’t be able to perform with the interstitial page coming up - but I can see Pagespeed consistently is pulling a previous version of my website.

After reading this twice, I’m not sure what the question is. But if you’d like our opinion on the situation, please post the domain name.

I apologize. The domain is retirewell.pro

Let me try to be more succinct and start here:

After switching to Cloudflare, when I make an update to my web page, it is no longer immediately reflected when I run a speed test on google pagespeed insights, as well as other page analyzers. It is analyzing the previous version of my site that is sitting in a cache somewhere.

I can have tried all the usual cache flushing techniques. Switching the nameserver is the only thing that works.

Pagespeed, besides its intended purpose, I use as a last ditch test to confirm changes I make are reflective on the www

I see three issues:

  1. You have caching at the server, as evidenced by the x-cache-hit header
  2. I’m pretty sure you have a Page Rule set to Cache Everything, as evidenced by the cf-cache-status hear, but a lack of APO headers. This is a problem, as there are unintended consequences for using a Cache Everything rule on a WordPress site.
  3. You said you Paused Cloudflare, yet the problem persisted. So that rules Cloudflare out, and most likely points to #1 above as being the problem.

Alright. I am hosting with godaddy (I know, I know). However, godaddy I am fairly certain has caching. So I went ahead and turned off the Cache Everything rule.

1 Like

Regarding x-cache-hit, are you saying I should turn OFF caching at the server? Not sure if that is possible with Godaddy, I believe their caching is automatic. I have turned off their CDN as I found their regular hosting to be faster than the CDN on my very light website.

Can anyone take a look at my headers and see why things arent updating properly?

I have no page rules on at the moment because I am concerned it will conflict with godaddys caching

The page seems to significantly lag to load, especially the first time of course. I showed it to a user and after loading the first page he clicked on another one and waited and before it loaded he had enough time to say “so you only have the home page done so far, huh”…

It’s actually looking quite good. Home, About, and Why Us load for me in just over a second. Contact has a lot more going on and takes a few seconds. Still, it’s quite impressive, as Cloudflare isn’t caching anything. Is the site still in Development mode?

The only thing that looks a little off is the Legacy Planning page. The text background is missing. No other page shows this way.

Will the cf-cache-hit show HIT even when there is no page rule??

I don’t have development mode on. Hopefully you will see this soon but if you do the below pagespeed test, you will see even google is not seeing the most recent version of my website. In the H1 “clients” has TWO apostrophes, when I removed that hours ago

https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fretirewell.pro%2F

Oddly, on my mobile phone, it IS updated.

I am also running permatters. Should I remove that app. To see if I could resolve some issues, I upgraded to the $20 pro plan and installed the app onto wordpress FYI. Also, I thought the $20 plan entitled me to tech support - was I wrong about that?

Sorry if these questions are basic, n00b here

Even now, a few hours later, google pagespeed insights reflects the wrong version of my website as well as a few browsers… my mobile remains up-to-the-moment accurate… see for yourself, when you run the pagespeed insights look at the image of the home page…the word “clients” has TWO apostrophes there, I have fixed that error and it only has one apostrophe… keep in mind, I am just using this example to demonstrate the point that it seems the web page changes are not reflecting entirely properly on the www

https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fretirewell.pro%2F

vs

Same problem as before. This isn’t a Cloudflare issue.

Could it be the managed wordpress via godaddy?

I am not sure what you are implying?? You are saying there appears to be two caching mechanisms at the same time?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.