Page caching when Ddos

Hello, when you turn off DDoS protection (VAF) when switching from the Yandex search engine from a mobile device, the main page does not load correctly, the styles are confused. On PC everything is fine.

Wonder if it could be due to the temporary Web browser cache on your mobile device due to the “I am under an attack!” mode being enabled for some time? :thinking:

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Are you using some custom-made Page Rules with an option like Cache Level: Cache Everything?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Before moving to Cloudflare, was your Website working over HTTPS connection?

Does it work as expected when you temporary Pause the Cloudflare for your zone?
Furthermore, you could determine if this behaviour continues even by using a “Pause” option at Cloudflare as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache on a mobile device?
How about using a Private window (Incognito mode) or a VPN connection if possible?

Is it the same behaviour on your mobile device when using the 4G LTE / mobile data vs home WiFi?

Thank you, it’s fixed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.