Packet loss measurement result is not showing and getting an error message of Unable to perform measurement: ICE connection timeout!

There is no domain name exposed by the Cloudflare Internet Speed Test.
My search brought me to this community to a topic with the same descriptive name but which was closed for inactivity. If you look you will find a closed topic of the same name.

The error message appears in the Packet Loss Test tile on the speed test results screen of [Internet Speed Test - Measure Network Performance].

What brings me here, to this community, is that my ISP does not see any problem when I begin to have connection issues with certain games and their servers. Upload/Download and streaming appear to be unaffected. However, certain network conversations fail with unhelpful messages like “connection failed”. However, coincident with these failures the Cloudflare Internet Speed Test Packet Loss Test fails but NOT with packet loss. It fails to successfully complete its server selection process from what I read about ICE.

The message is in the Packet Loss Test tile and reads:
Unable to perform measurement: ICE connection timeout!

What steps have you taken to resolve the issue?

  1. Many suggestions were oriented to picking a known good/reliable DNS server
  2. Many suggestions were made that this had to do with my equipment
  3. Many suggestions were made that it is somehow a bandwidth issue <don’t believe this>

This has nothing to do with being a Cloudflare customer. I want to know what this error message means in terms of what I can tell my ISP in the spirit of “helping them diagnose their problem”.

What are the steps to reproduce the error:

  1. Comes and goes, persists for hours, have attempted to influence when it occurs and failed.
  2. Tried stressing the connection
  3. Tried stressing the laptops

Does not appear to be specific to any browser. Does not seem to be specific to Cloudflare Internet Speed test. The Ookla speed test also fails but does not provide anything as specific as the Cloudflare Internet Speed Test does. Ookla simply says they cannot complete their test.

Has anyone see this or know what exactly the traffic is involved in the ICE connection and what an ISP (their equipment or servers) might do the cause these ICE timeouts? In the end I want to connect this back to my ISP and their diagnostic process.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.