Override DNS policy doesn't seem to be working

Good morning everyone!

We’re using Cloudflare Teams Standard as a VPN replacement. I’d like to override DNS response for some hostnames so users could access them without modifying local hosts file. So, right now I have a test web server in my private network that I can successfully reach via tunnel:

I build an override policy as such:

But example.com still resolves to its regular public IP:

I also tried setting the condition as “host is” to the same effect.

Any hints what am I missing? Thank you!

I think I figured. I did not create a default location and did not change my nameservers in Windows settings. I somehow assumed WARP client takes care of this automatically.

Upd: changing nameservers is actually not necessary. So it was just the default location that was missing.

1 Like