Outlook client cannot connect to email server

After activating Cloudflare, my Outlook email client cannot now connect to my email server.

As per instructions in other support articles, I have set the following DNS records in cloudflare:

A, mail, IPxx.xx.x.xxx, Auto, DNS only (grey cloud)
MX, domain, mail.domain, 10, Auto, DNS only
MX, domain, mail.domain, 20, Auto, DNS only

But my outlook client still cannot connect, any help would be greatly appeciated.
Thanks.
Paul

Hi @paulbrady15,

What ‘server name’ is specified in Outlook to connect to? It should be the :grey: mail.domain hostname.

Hi domjh,
Yes, it is set to mail.domain.com

I now see that there are no emails being delivered or sent via my webmail as well, not just outlook. It shouldn’t be this hard to get it working on cloudflare…

Are you able to share the domain name in question so we can have a look?

wifzack.com is the domain.
I’ve just had to pause the service as I need my business emails working (they haven’t been since activating it yesterday).
If we can resolve this, then I can reactivate it.
Thanks

Great, think I see the issue. Now you are pointing back to your host’s nameservers, looks like your MX record should not be mail.yourdomain.com but you should have 2:

mx1.cloudhosting.co.uk. Priority 10 mx2.cloudhosting.co.uk. Priority 20

Can you change the MX record in Cloudflare to point to here and add another for the second one and it should work for you.

While you’re there, just check that the SPF is in Cloudflare OK as well:

“v=spf1 +a +mx +ip4:77.72.0.166 ~all”

Ok, I can do that but why should it be cloudhosting.co.uk and 77.72.0.166?
These are not my host (Krystal) or my ip address, or am I misunderstanding something?

Ok, now that’s weird…

Either I mis-copied the domain or something went wrong! Sorry!

Will try again!

MX records:

mx1.krystal.co.uk. Priority 10
mx2.krystal.co.uk. Priority 20

SPF record:
"v=spf1 +a +mx +ip4:77.72.0.194 ~all"

Those are the existing MX and SPF records from the initial setup and haven’t changed.

I am so confused now! Sorry!

A, mail, IPxx.xx.x.xxx, Auto, DNS only (grey cloud)
MX, domain, mail.domain, 10, Auto, DNS only
MX, domain, mail.domain, 20, Auto, DNS only

When you said mail.domain, I thought you meant your domain.


If all your DNS records match, can you change back to Cloudflare’s nameservers but pause Cloudflare on the site. This will narrow down the issue.

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

Yes, all the DNS records seem to match.
However, I cannot change back to Cloudflare’s nameservers at the moment as we have important business emails which we need to send & receive today and cannot afford any problems. So, I can only do that another day…

OK, with Cloudflare paused they are only providing the DNS, if all the DNS records are the same then it should all work the same when you do switch back. If all works fine then but not when you enable Cloudflare then please just post back so we can help you further.

Again, sorry about the confusion!

Thanks & no problem re: the confusion.
I will post back once I have re-enabled Cloudflare.

1 Like

Hi @paulbrady15,

Looks like this other thread may help you :slight_smile: