Outgoing mail is not working PTR records not working although PTR Records are set

Incoming email is working fine. But outgoing email is not working. Following error is happening on our side.

Undelivered Mail Returned to Sender

550-5.7.25 [103.115.24.11] The IP address sending this
message does not have a 550-5.7.25 PTR record setup.

Details in image:

May I ask are you using a shared hosting or a VPS/dedicated server?

  • cloudone

For your IP address via which you are sending e-mails, there is no hostname setup (rPTR record as you stated).
Usually the owner can setup this for given static IP of our VPS/cloud/dedicated server in the interface by it’s hosting provider.
Nevertheless, owners can configure it in their origin host/server hosts files and other services (postfix …).

I am afraid Cloudflare can not set a PTR record for your domain. This should be done through your hosting IP provider.

Or rather, the provider is the ISP and not the hosting one? In this case, the PTR record is handled by your ISP.

Some e-mail providers reject the e-mails from senders with no hostname defined.

Other things I have checked so far:

I see the technova.com.bd is using Cloudflare nameservers.
Therefore, A record is not proxied :grey: (DNS-only), correct?, while the A www record is proxied.

May I ask if you are using mail.technova.com.bd for incoming/outgoing server, or rather technova.com.bd (should be proxied :orange: too) in your e-mail client (MS Outlook, Mozilla Thunderbird …)?

Furthermore, your MX record is pointing to the unproxied mail.technova.com.bd which is good.

And, you have a TXT record for SPF in which you included the correct IP address of your e-mail provider.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.